Los siguientes errores pueden encontrarse durante la conversión de un curso a un formato D2L. Primero intente con estos pasos de solución de problemas y, si no funcionan, póngase en contacto con el equipo de soporte para realizar una investigación más profunda del problema.
Error: el paquete no se reconoció
Es posible que un paquete no se reconozca si:
- No se encuentra en un formato de archivo de curso (por ejemplo, es un archivo .ppt o .pdf en lugar de un paquete de curso exportado desde un LMS).
- Se exportó desde un proveedor que aún D2L no admite.
- No pudo descomprimirse.
El paquete no pudo descomprimirse
Síntomas
Cuando importa un paquete del curso, se encuentra con el mensaje: “El paquete no se reconoció”. Los registros de procesamiento indican "Desempaquetando el archivo cargado" seguido de "Formato de archivo no compatible". Si el paquete se descomprimió de manera correcta, los registros de procesamiento indicarían "Archivo desempacado de manera correcta".
Los registros de procesamiento también indicarán que el estado final del problema era "NoConversion". Puede acceder directamente a los registros de procesamiento en la página de errores en Importar cursos; para ello, haga clic en "Ver registros de procesamiento".
Causa
Las siguientes son causas comunes de este error:
- El paquete no es un archivo válido (por ejemplo, .zip, .mbz, .imscc, etc., que se han exportado desde un LMS). Verifique que el tipo de archivo sea Archivo o Carpeta comprimida antes de intentar la importación del curso. Los siguientes tipos de archivo no son válidos para la importación de un curso: .pdf, .ppt, .docx. Si intenta agregar contenido del curso, utilice la herramienta Contenido; Agregar módulo.
- El paquete de curso no tiene el archivo imsmanifest.xml en el nivel raíz y es posible que se ubique en una subcarpeta.
- El paquete del curso contiene rutas de archivos que tienen más de 128 caracteres, que es un límite de Windows.
- Un archivo que se ha dañado o deteriorado.
Solución
Si utiliza un archivo para verificar si puede extraerse el paquete del curso, primero intente descomprimir el paquete de manera local. Intente los siguientes pasos para resolver el problema:
- Use el programa de extracción incorporado del sistema operativo y trate de descomprimir el archivo en su computadora.
Si descomprime correctamente el paquete en su computadora local, vuelva a comprimir el archivo con el programa de compresión del sistema operativo local o el programa que estaba usando. Vuelva a intentar la importación del curso con el paquete recién comprimido.
- Descomprima el paquete y examine la estructura de las carpetas para garantizar que el archivo imsmanifest.xml esté en el nivel raíz. Si el archivo imsmanifest.xml no está en el nivel raíz, mueva el archivo a esta ubicación, vuelva a comprimir el paquete y reintente la importación del curso.
- Use WinRAR (http://www.rarlab.com/) para descomprimir el archivo en su computadora.
Su paquete puede contener rutas de archivo que superan los 128 caracteres. En este caso, la mayoría de los programas de extracción en Windows fallarán. WinRAR extraerá los archivos, pero advertirá que los archivos que excedan la longitud máxima de la ruta van a aparecer truncados. Una vez que se completa la extracción, se recomienda que estas rutas se trunquen de manera manual o que se eliminen. Luego, vuelva a comprimir los archivos y reintente la importación del curso.
- Vuelva a exportar el paquete del curso desde la fuente original.
Si ninguno de los pasos de solución de problemas funcionó y la extracción sigue fallando, es posible que el paquete del curso esté dañado. Vuelva a exportar el paquete del curso desde el LMS original y reintente la importación del curso con un paquete recién exportado.
Error: el paquete no se convirtió
Este error normalmente surge debido a problemas con el paquete del curso en sí:
- Es posible que falten archivos clave (por ejemplo, imsmanifest.xml es un archivo habitual que se espera que figure entre la estructura del paquete del curso).
- Es posible que existan problemas con XML en algunos de los archivos (por ejemplo, los archivos pueden tener caracteres no válidos o paréntesis de apertura y de cierre no coincidentes).
Por lo general, se recomienda revisar los registros de procesamiento e inspeccionar la queja específica. A continuación, explore el contenido del paquete para verificar que la información sea correcta. También puede intentar volver a exportar el paquete desde la fuente original.
HTML no válido
Síntomas
Cuando importa un paquete del curso, se encuentra con el mensaje "El paquete no se convirtió". Los registros de procesamiento pueden indicar que se ha encontrado un carácter no válido o inesperado.
Los registros de procesamiento también indicarán que el estado final del problema era "ProcessingFailed". Para acceder directamente a los registros de procesamiento en la página de errores en Importar cursos, haga clic en Ver registros de procesamiento.
Causa
Un XML no válido a menudo puede hacer que las conversiones fallen. A veces el error nombra directamente el archivo exacto que está causando el problema. Si no se lo indica de manera explícita, pruebe con el archivo imsmanifest.xml principal. Si el manifiesto se forma de manera inadecuada, pueden producirse graves problemas.
Solución
Para verificar que un archivo XML sea válido:
- Abra el archivo en Google Chrome. Si el XML es válido, debe representarse de manera correcta; si no lo es, la página permanecerá en blanco o se informará la existencia de un error.
- Utilice un validador XML en línea como: http://www.xmlvalidation.com/
- Si el XML no es válido, corrija el XML, vuelva comprimir el paquete y reintente importar el paquete del curso.
- Si el XML es válido, es probable que el problema con el paquete esté en la estructura del paquete (por ejemplo, la falta de archivos clave). En este caso, vuelva a exportar el paquete desde la fuente original y reintente importar el paquete del curso.
Error: el servicio de conversión no está disponible temporalmente
Si el Servicio de conversión no está disponible, es posible que se deba a problemas temporales que el equipo de soporte de D2L está supervisando y que se resolverán en breve. Sin embargo, si observa de manera reiterada este mensaje de error, considere la posibilidad de verificar que la dirección URL del Servicio de conversión esté configurado de manera adecuada. Solo un representante del equipo de soporte de D2L puede realizar esto.