قد تحدث الأخطاء الآتية في أثناء تحويل المقرر التعليمي إلى تنسيق D2L. جرِّب خطوات استكشاف الأخطاء وإصلاحها هذه أولاً، وإذا لم تنجح، فاتصل بالدعم لمزيد من التحقيق المتعمق في المشكلة.
خطأ: لم يتم التعرف على الحزمة
قد لا يتم التعرف على الحزمة في حالة:
- ليست بتنسيق أرشيف المقرر التعليمي (على سبيل المثال، كانت ملف .ppt أو .pdf بدلاً من حزمة مقرر تعليمي يتم تصديرها من نظام إدارة التعلّم).
- تم تصديرها من مورّد غير مدعوم من D2L حتى الآن.
- تعذر إلغاء ضغطها.
تعذر إلغاء ضغط الحزمة
الأعراض
عند استيراد حزمة مقرر تعليمي، تظهر لك الرسالة: "لم يتم التعرف على الحزمة". تظهر سجلات المعالجة "جارٍ فك حزمة الملف الذي تم تحميله" تتبعها "تنسيق الملف غير مدعوم". إذا تم إلغاء ضغط الحزمة بنجاح، فستظهر سجلات المعالجة "تم فك حزمة الملف بنجاح" بدلاً من ذلك.
كذلك توضح سجلات المعالجة أن الحالة النهائية للمشكلة هي "NoConversion". يمكنك الوصول إلى سجلات المعالجة مباشرةً من صفحة الخطأ في استيراد المقرر التعليمي بالنقر فوق "عرض سجلات المعالجة".
السبب
فيما يأتي الأسباب الشائعة لهذا الخطأ:
- الحزمة ليست ملف أرشيف صالح (مثل zip. وmbz. وimscc. ونحوها مما تم تصديره من نظام إدارة التعلّم). تحقق من أن الملف من نوع ملف الأرشيف أو المجلد المضغوط قبل محاولة استيراد مقررك التعليمي. لا تصلح أنواع الملفات الآتية لاستيراد مقرر تعليمي: .pdf و.ppt و.docx. إذا كنت تحاول إضافة محتوى مقرر تعليمي، فاستخدم أداة المحتوى - إضافة وحدة نمطية بدلاً من ذلك.
- لا تحتوي حزمة المقرر التعليمي على imsmanifest.xml على مستوى الجذر، وقد يكون موجودًا في مجلد فرعي بدلاً من ذلك.
- تحتوي حزمة المقرر التعليمي على مسارات ملفات أطول من 128 حرفًا، الحد الذي يسمح به Windows.
- ملف أرشيف تالف أو متضرر.
الحل
إذا كنت تستخدم ملف أرشيف، فحاول إلغاء ضغط الحزمة محليًا أولاً للتحقق من إمكانية استخراج حزمة مقررك التعليمي. حاول اتباع الخطوات الآتية لحل المشكلة:
- استخدم برنامج الاستخراج المضمن في نظام التشغيل، وحاول إلغاء ضغط الملف على الكمبيوتر لديك.
إذا قمت بإلغاء ضغط الحزمة بنجاح على الكمبيوتر المحلي، فأعِد ضغط الملف باستخدام برنامج الضغط المحلي على نظام التشغيل لديك أو البرنامج الذي كنت تستخدمه. أعِد محاولة استيراد المقرر التعليمي بالحزمة المضغوطة حديثًا.
- قم بإلغاء ضغط الحزمة وافحص بنية المجلد للتأكد من وجود ملف imsmanifest.xml على مستوى الجذر. إذا لم يكن ملف imsmanifest.xml على مستوى الجذر، فانقل الملف إلى هذا الموقع وأعِد ضغط الحزمة وحاول استيراد المقرر التعليمي مرة أخرى.
- استخدم WinRAR (http://www.rarlab.com/) لإلغاء ضغط الملف على الكمبيوتر لديك.
قد تحتوي الحزمة على مسارات ملفات أطول من 128 حرفًا. في هذه الحالة، ستفشل معظم برامج الاستخراج على Windows. إلا أن برنامج WinRAR سيستخرج الملفات، لكنه سيعطي إنذارًا بأن الملفات التي تتخطى الحد الأقصى لطول المسار تم اقتطاعها. بعد اكتمال الاستخراج، يوصَى باقتطاع هذه المسارات يدويًا أو إزالتها. ثم أعِد ضغط الملفات وحاول استيراد المقرر التعليمي مرة أخرى.
- أعِد تصدير حزمة المقرر التعليمي من المصدر الأصلي.
إذا لم تنجح أي من خطوات استكشاف الأخطاء وإصلاحها السابقة ولم يزل الاستخراج متعذرًا، فمن المرجح أن تكون حزمة مقررك التعليمي تالفة. أعِد تصدير حزمة المقرر التعليمي من نظام إدارة التعلّم الأصلي وحاول استيراد المقرر التعليمي مرة أخرى بحزمة تم تصديرها حديثًا.
خطأ: لم يتم تحويل الحزمة
يظهر هذا الخطأ بشكل شائع بسبب مشكلات في حزمة المقرر التعليمي نفسها:
- قد تكون ثمة ملفات أساسية مفقودة (على سبيل المثال، ملف imsmanifest.xml الذي عادةً ما يُتوقع أن يكون موجودًا من بين بنية حزمة المقرر التعليمي).
- قد تكون ثمة مشكلات مع XML في بعض الملفات (على سبيل المثال، قد تحتوي الملفات على أحرف غير مسموح بها أو أقواس بداية ونهاية غير متطابقة).
عادةً، يوصى بمراجعة سجلات المعالجة وفحص الشكوى المحددة. وبعد ذلك قم باستكشاف محتويات الحزمة للتحقق من تصحيح المعلومات. يمكنك أيضًا محاولة إعادة تصدير الحزمة من المصدر الأصلي.
HTML غير صالح
الأعراض
عند استيراد حزمة مقرر تعليمي، تظهر لك الرسالة "لم يتم تحويل الحزمة". قد تشير سجلات المعالجة إلى العثور على حرف غير صالح أو غير متوقع.
كذلك توضح سجلات المعالجة إلى أن الحالة النهائية للمشكلة هي "ProcessingFailed". للوصول إلى سجلات المعالجة مباشرةً من صفحة الخطأ في استيراد المقرر التعليمي، انقر فوق عرض سجلات المعالجة.
السبب
غالبًا ما يؤدي استخدام XML غير صالح إلى تعذر عمليات التحويل. في بعض الأحيان، يسمي الخطأ مباشرةً الملف الذي يسبب المشكلة بالتحديد. إذا لم يتم ذكره بشكل صريح، فجرّب ملف imsmanifest.xml الرئيسي. إذا لم يتشكل البيان بشكل صحيح، فقد تحدث مشكلات خطيرة.
الحل
للتحقق من صلاحية ملف XML:
- افتح الملف في مستعرض Google Chrome. إذا كان XML صالحًا، فيجب أن يعرض بشكل صحيح؛ وإذا لم يكن كذلك، فستبقى الصفحة فارغة أو ستبلغ عن وجود خطأ.
- استخدم مدقق XML عبر الإنترنت مثل: http://www.xmlvalidation.com/
- إذا كان XML غير صالح، فقم بتصحيح XML، وأعِد ضغط الحزمة وحاول استيراد حزمة مقررك التعليمي مرة أخرى.
- إذا كان XML صالحًا، فمن المرجح أن تكون مشكلة الحزمة في بنيتها (على سبيل المثال، ملفات أساسية مفقودة). في هذه الحالة، أعِد تصدير الحزمة من المصدر الأصلي، وحاول استيراد حزمة مقررك التعليمي مرة أخرى.
خطأ: خدمة التحويل غير متوفرة بشكل مؤقت.
إذا لم تكن خدمة التحويل متوفرة، فقد يرجع ذلك إلى مشكلات مؤقتة يتابعها دعم D2L وسيتم حلها قريبًا. ومع ذلك، إذا رأيت رسالة الخطأ هذه بشكل متكرر، فقد يكون من المفيد التحقق من تكوين عنوان URL الخاص بخدمة التحويل بشكل صحيح. وذلك لا يمكن القيام به إلا من خلال أحد ممثلي دعم D2L.