Enabling Intelligent Agent(s) in Course Offerings

Options

Hi Everyone, is there a way as a Sys Admin I could enable the IAs in all courses using a filter of some sort?

Basically, we have IA's setup in a template that will be copied over when our courses are created using IPSIS. However, the AI's are created but not enabled in the course itself even if they are enabled in the template. So it leads to the question, how can I enable the IAs in all the courses without having to go into each course? I was thinking there has to be a way. We just assume not having our instructors perform the task and we do it ourselves.

Thanks for any ideas or ways to accomplish this if it's possible!

ShawnP

Best Answer

  • Andrea.M.553
    Andrea.M.553 Posts: 77
    Answer ✓
    Options

    Oh, you are correct. I switched them by accident.

    It should look something like this for them to be enabled when you copy.

Answers

  • Andrea.M.553
    Andrea.M.553 Posts: 77
    Options

    Hello,

    There is a configuration variable that determines if intelligent agents are enabled when courses are copied.

    It is d2l.Tools.IntelligentAgents.DisableAgentsOnCopy.

    It sounds like your instance is set to OFF, but you can override it to ON, and then they will be set to ON for the orgunits you select.

    Best,

    Andrea

  • Shawn.P.251
    Shawn.P.251 Posts: 16 🌱
    Options

    Thanks Andrea. For clarification. The Default Instance Value is set to ON which means the IA were copied from the template to the course but not enabled.

    Therefore I'll need to Add Value ( My Template Org Unit to OFF).

    Maybe it's it me but it can be confusing. If the d2l.Tools.IntelligentAgents.DisableAgentsOnCopy is set ON it means DISABLE the copied IA in the course, this correct? (As the configuration name implies)

  • Shawn.P.251
    Shawn.P.251 Posts: 16 🌱
    Options

    Hi Andrea, thanks again. I actually did what you suggested and it worked. I basically added the template as an override value and set it to off. Result: copies IAs over and enables them.

    I was talking with a colleague and we both agreed that using a tool name ".DisableAgentsOnCopy…" with a default value of ON doesn't make sense in a way. It would have been better to call the tool ".EnableAgentsOnCopy…" with the default value of OFF. This makes a lot better sense! To me anyway… :-)

    ShawnP

  • Andrea.M.553
    Andrea.M.553 Posts: 77
    Options

    Double negatives! So frustrating!