Getting a permissions error when trying to use SQL

Options

Answers

  • Joshua.V.999
    Joshua.V.999 Posts: 17
    Options

    William, can you provide some additional context as to what you are trying to do here and how you are attempting to execute SQL against your environment to ensure the right team can provide guidance here?

    Thanks

    -Josh

  • William.E.2474
    William.E.2474 Posts: 3 🔍
    Options

    I go into Insights Portal and open the analytics builder. Click on Datasets on the left and then New Dataset in the upper right. Click on Brightspace and then Athena. Neither of the dropdowns have any other selections.

    I select activiyexemptionslog_9_4_2 and click Use Custom SQL and this window opens:

    I type in select * from actvityexemptionsleog_9_4_2 and get the error I reported. (BTW - I looked for SQL syntax in the help but found nothing. It would be great to get to a developer app where the query language and conventions are displayed)

    Thanks for you quick response. I also emailed our local administrator but have not gotten a response.

  • Jennifer.W.973
    Jennifer.W.973 Posts: 247 🌟
    Options

    @William.E.2474 You have to enter the database name before the table name. There is an Analytics Builder course in the Learning Center (linked in the sidebar on this page) which includes this tip in the bonus module:

    • Initially, the table name needs to be manually entered into the SQL query. Subsequently the table name will auto-populate within the custom SQL query interface.
    • It is required to add the Schema before the data set path, this is available on the left side of the SQL editor. For example, rather than users_9_5_2 you would enter:

    brightspace_data_sets_16bff143_2b30_4082_8fec_1467430d032c.users_9_5_2