Single Profile Widget Picture Not Showing

Options

Greetings!

There was a time when I could see my picture in the Single Profile Widget that is show on the main page. I use Firefox and have set up my sites the New Experience mode.

I am told that others can see the picture, but I am puzzled by the fact that I can't see it. I've embedded images in other parts of my sites and can see them fine. And, further, I can see the file for the image in the custom_widgets > teacher_profile > img subfolder of my site.

Best Answer

  • Mohit.B.878
    Mohit.B.878 Posts: 47
    Answer ✓
    Options

    Hello @Darren.S.643
    Thank you for reaching out to D2L through the Brightspace Community.

    We have a Defect Logged for the Single Profile Widget not working for Firefox as expected under the Defect number: 02004431.

    According to the defect, the issue with images not displaying within the Single Profile Widget in Firefox is related to the browser's settings. Specifically, when "Enhanced Tracking Protection" is enabled in Firefox, it actively blocks cookies, leading to the images not being displayed. However, in other browsers where cookies are not blocked, the images appear correctly.

    The current workaround for the issue is to either disable "Enhanced Tracking Protection" for Firefox. I've attached documentation from Firefox on how to do this: [  https://support.mozilla.org/en-US/kb/third-party-cookies-firefox-tracking-protection ]. Alternatively, you can use any other browser to access the site.

    Hope this helps.


    Best regards,
    Mohit Bhargav

Answers

  • Darren.S.643
    Darren.S.643 Posts: 4 🌱
    Options

    Thank you so much for your response, Mohit! This is very helpful.

    I found the cookies issue to be confusing because I have my institution's URL for BrightSpace on my Firefox whitelist. And, I also don't delete my cookies. After slightly adjusting the settings in Firefox, I managed to see the image in the Single Profile Widget. Since I hadn't made any changes to these settings in many months, it was simply puzzling to not be able to see the image when I could see it about a couple months ago.

    My institutional contact also asked if I use AdBlock, which I do. So I've turned that off for my institution's URL for BrightSpace. Doing this did not seem to make any difference.

    All the same, everything seems to be ok.

  • Mohit.B.878
    Mohit.B.878 Posts: 47
    Options

    Hello @Darren.S.643

    Thanks for letting us know that we were able to resolve the raised issue.

    Best regards,
    Mohit Bhargav