error when clicking into course: An embedded page at ...

Julie.S.907 Posts: 4 🌱
edited October 2023 in Higher Ed / Postsecondary

A user gets this error when clicking into a course homepage (the error re-appears if you click OK, navigate to content, and click back to Course Home):

An embedded page at says
Error retrieving credentials

Any idea what is causing this?



  • Marcel.Z.297

    Goodmorning Julie,

    I experienced the same problem. Clearing the cache and cookies from the browser solved it for me.


  • Tracy.W.238
    Tracy.W.238 Posts: 11 🌱
    edited September 2023

    We are seeing the same thing here. I tried running a session for staff yesterday and it continuously popped up for both myself and the participants. This morning I have teachers reaching out that the issue is continuing. We'll try clearing the cache and cookies to see if it helps.

  • Julie.S.907
    Julie.S.907 Posts: 4 🌱

    Clearing the cache worked for me, too, but that doesn't resolve why this is happening. Does anyone have insight into the why?

  • Pulkit.Y.864

    Hi everyone,

    This issue is happening because the course is using an older version of the widget and the user most likely has the previous version of the widget cached.

    Clearing the browser cache should fix the issue.

    This is a good reminder that this is the hosted version of the Visual Table of Contents widget, and these versions are going to be end-of-life. The better solution (long term) would be to migrate the course homepages to the System version of this widget, as it doesn't have this problem.

    You can read more about End Of Life of the Widget here: