Why can I not make my course available in Discover?

Options

I'm setting up a course and would like learners to be able to self-enroll via Discover. I know the course must be active, and that box is checked off. However, I still can't check off the box, “Make this course available in Discover so Learners can self-enroll.”

What am I missing?

Best Answer

  • Sam.B.358
    Sam.B.358 Posts: 11
    Answer ✓
    Options

    Do you have a custom role that you're enrolled in the course as or in as an admin?

    I can only get that X to show up when I turn this permission on and off at the admin level.

Answers

  • Craig.R.185
    Options

    Hi @Kate.Richardson9949 . Checking the “Make this course available in Discover, so Learners can self-enroll” checkbox is all that's needed. I find it usually takes a minute or so for the course to appear in Discover, however, which might be what's happening for you.

  • Kate.Richardson9949
    Options

    Hi @Craig Rom66, that usually works for me too. However, the checkbox is not available this time and I only see a gray X.

  • Kate.Richardson9949
    Options

    Thank you. You're right— this permission was turned off for my role (super designer) in this instance of Brightspace. Glad to have found the reason.

    -Kate