D2L API - OAuth2.0 isn't working as expected.

Hey there,
I am trying to use D2L API for fetching courses and assignment details in our application.
I did registered the application and got my client_id and client_secret. This is good. But when I follow the document of D2L Oauth2.0 testing using postman it doesn't quiet allow me to authenticate the application .

Here are the steps which I followed:

- Video Link : https://www.loom.com/share/90e6098521e74912b2e069b7bca1a409?sid=4b675e93-b675-458e-8bc3-01c5ba4f4aec
- We are trying to use D2L API and following the doc:

Following are the steps we followed for the API Access:

1. Registered the app on Brightspace D2L platform.
2. Using Postman ( API Testing Tool ) to perform authorization request.
3. User will be prompted to login to Brightspace if they are not logged in already.
4. Upon successful login, the user will be presented a page where they can confirm if the allow the appliation to act on its behalf.
5. This prompt ( Microsoft Login ) is different than the usual prompt to login as an instructor. But ends up with an Error - The Login was successfull, but doesn't meet the criteria to access this resource.
6. Wondering what could be the reason for the error, Is there anything which is missed from our end to be included in the authentication request ?
7. We tried with Amanda’s credentials too but ended up with the same error. Upon multiple try this ended up blocking her account.

Note: Amanda is one of the Administrators for University who are using D2L.

I would really appreciate an ASAP response to this as D2L Authentication has become a blocker for us at the moment.