Message Alerts Icon on the Minibar: MIA

Alec.C.679
Alec.C.679 Posts: 12 🌱
edited July 2023 in Customer Enablement

Hi everyone! 😁

I'm wanting to test out the Instant Messages tool in our organisation, but I can't seem to figure out how to access the envelope icon for 'Message Alerts'.

I have the 'Access Instant Messages' and 'Add Friends by Username' permissions enabled for my role which lets me see the Instant Message button on the Classlist tool. But my minibar does not have the Message Alerts button πŸ˜–

Below is what my minibar setup looks like:

I'm sure that I am simply forgetting to enable a permission or config variable, any help or advice would be much appreciated!

Best Answers

  • Chris.S.534
    Chris.S.534 Posts: 200
    Answer βœ“

    Hi Alec,

    If you have the permissions to access the Config Variable Browser please check d2l.Settings.Navbar.HideMessageAlerts for the right setting. Also be sure to double check user roles and role permissions are so users can/cannot access the tools as appropriate for when you do activate the tool.

    Ideally tool testing and permissions changes would be done in a test environment (if available), thereafter the change rolled out to the production environment.

    Hope that helps!

  • Bharti.B.332
    Bharti.B.332 Posts: 94
    Answer βœ“

    Hello @Alec.C.679

    There is a config variable called "d2l.Settings.Navbar.HideMessageAlerts ( Org )" that controls this setting, I recommend checking the current org value for this setting.

    Thanks and Regards,

    Bharti

Answers

  • Alec.C.679
    Alec.C.679 Posts: 12 🌱

    Thank you both @Bharti.B.332 and @Chris.S.534, I had forgotten to mention in my post that I initially edited this setting and unfortunately it didn't add the icon.

    I can't imagine this would impact anything, but it might be worth noting that I have the permissions enabled for SuperAdmin and Admin roles only - the thinking behind this is so I can test this function before opening it up to our Learners.