Chapter names will not appear on videos, but chapter timestamps are

Options
Alyssa.F.487
Alyssa.F.487 Posts: 2 🌱

I am working in New Content. I have uploaded mp4 files to MyMedia, and then added Auto-generated captions and chapters to the videos. Once the captions were generated, I edited them. They show up in the video. I then edited the chapter timestamps and added names. The timestamps appear, but the names do not when I embed the video on an HTML page using Insert Stuff > MyMedia> Choose the updated file.

I tried renaming the files, doing a hard refresh, etc. I have tried Optimizing them for Streaming.
One thing I do notice: when I go back to the file in MyMedia, it defaults to language: English - USA. When this language is the default, the chapter names do not appear in MyMedia either, though the Chapter timestamps do.

But, when first editing the video, I Auto-generated the captions using the language English - Canada. When I switch to that language when viewing the file in MyMedia, the caption text appears next to the timestamps. Not sure if it's referring to an English-USA version of the video, and how I get the Video to stop defaulting to that if that's what's happening?

This hasn't happened for other video files I've uploaded, auto-generated captions for, or edited. Thanks!

Answers

  • Julie.L.787
    Julie.L.787 Posts: 297 admin
    Options

    Hi @Alyssa.Filippi2596 ,

    Thanks for connecting with the Brightspace Community!

    I shared your question with our experts and, in this case, we recommend you log a support ticket. We were unable to reproduce this on our end when we attempted to troubleshoot. The ticket will allow our folks to take a closer look at what may be happening within your learning instance😀

  • Alyssa.F.487
    Alyssa.F.487 Posts: 2 🌱
    Options

    I fixed it - It had to do something with the Auto-generated captions.

    Since my captions were auto-generated in English-Canada, the Chapter names somehow only populated in the version of the video that was English-USA, even though the timestamps showed up for both. English-USA seems to be the default English version for video when you first go into the Advanced Video Editing screen.
    So, I just re-added the names of the Chapters in English-USA, even though there were no English-USA captions auto-generated, and then the English-Canada captions and Chapter titles and time stamps all showed up on the embedded videos (captions and chapter titles) once saved.

    Not sure if it's a bug or error, but I found this workaround for anyone else who happens across the same thing.