Semester filter under 'My Courses' not appearing

Options
Shawn.Bell7218
Shawn.Bell7218 Posts: 28 🌱
edited November 2022 in Customer Enablement

I would like to have seperate 'streams/semesters' of courses for our corporate education.

 

I have customized the widget so that 'semesters' is checked off but this tab from the below image is not appearing (see top image).

 

Thanks for your help!

 

snippy

Answers

  • Renee.J.194
    Renee.J.194 Posts: 114
    edited November 2022
    Options

    @Shawn Bell​ , it looks to me that the lower image is a user who is enrolled in courses that have semester associations, and the upper image is from someone who is enrolled only in courses without semester associations.

  • Shawn.Bell7218
    Shawn.Bell7218 Posts: 28 🌱
    edited November 2022
    Options

    @Renee Judd I am trying to setup semester associations but have been unsuccessful.

     

    Any ideas on how to achieve this? Thanks for your response!

  • Renee.J.194
    Renee.J.194 Posts: 114
    edited November 2022
    Options
    Is the picture with semesters from your own site or someone else's? If it is your own site, you need to edit the course offering that need semesters either in the org unit editor or in course offering information. If you do not have semesters at all for anything on your site, and that the picture with semesters is not yours, you need to work with your org structure. I would recommend a support case if you haven't done this kind of thing before. srj
  • Praful.R.602
    Praful.R.602 Posts: 25
    edited November 2022
    Options

    Hi Shawn,

     

    You will need to turn 'ON' config variable 'd2l.Tools.MyCoursesWidget.UpdatedSortLogic', then customize the widget and select group course by 'semester'.

     

     

    Please let me know if this is helpful.

     

    Regards,

    Praful

  • Shawn.Bell7218
    Shawn.Bell7218 Posts: 28 🌱
    edited November 2022
    Options

    Thank you everyone. @Praful Rodrigues​  This worked perfectly, thank you!